$re = '/\(\?<?[!=](?<r>[^()]|\(\g<r>+\))+\)/m';
$str = 'A(?<!B(C)D)E(?<=F)G(?!H(I(J))K)L(?=M(O)P)Q(?>R)S(T)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);