re = /\(\?<?[!=](?<r>[^()]|\(\g<r>+\))+\)/m
str = 'A(?<!B(C)D)E(?<=F)G(?!H(I(J))K)L(?=M(O)P)Q(?>R)S(T)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end