package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z0-9]{4}[0-9]{4}\d{12}\d{8}R\d{2}\d{4}`)
var str = `CNV6072103325000100120190429R070001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}