$re = '/[A-Z0-9]{4}[0-9]{4}\d{12}\d{8}R\d{2}\d{4}/m';
$str = 'CNV6072103325000100120190429R070001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);