import re
regex = re.compile(r"[A-Z0-9]{4}[0-9]{4}\d{12}\d{8}R\d{2}\d{4}", flags=re.MULTILINE)
test_str = "CNV6072103325000100120190429R070001"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")