#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\w*[ а-яА-Яa-zA-Z:,\/]*\\?$)|^\\*[\w .:]*\\*\/?(.*)"
Local $sString = "\\\\atxr2.atxr.ru\\_resource_test_001001\\_dir1" & @CRLF & _
"c:\\_resource_test_001001\\_dir1" & @CRLF & _
"\\atxr2.atxr.ru\_resource_test_001001\_dir1" & @CRLF & _
"D:\" & @CRLF & _
"_dir1" & @CRLF & _
"\\atxr2.atxr.ru\_resource_test_001004" & @CRLF & _
"Локальное имя" & @CRLF & _
"_resource_test_001004" & @CRLF & _
"Разделяемое устройство" & @CRLF & _
"atxr.ru/Users/Administrator" & @CRLF & _
"atxr2.atxr.ru/_resource_test_001004" & @CRLF & _
"atxr2.atxr.ru\_resource_test_001004" & @CRLF & _
"Удаление,Смена владельца документа,Смена владельца,Удаление документа,Просмотр разрешений документа,Просмотр разрешений,Управление документами,Управление принтером,Просмотр документов,Печать,Установка разрешений документа,Установка разрешений" & @CRLF & _
"Подразделение Active Directory" & @CRLF & _
"atxr.ru/_resource_test_0011015/_resource2_test_0011015" & @CRLF & _
"atxr.ru/_resource_test_0011015/_user1_test_0011015" & @CRLF & _
"Содержание папки/Чтение данных,Чтение дополнительных атрибутов,Обзор папок/Выполнение файлов,Чтение атрибутов,Чтение разрешений" & @CRLF & _
"" & @CRLF & _
"(^[\w а-яА-Я:]*\\?$)|(^[A-Z]{1}:\\$)|^[\\a-zA-Z0-9.-:]*[\\\/](.*)" & @CRLF & _
"(^[\w а-яА-Я:]*\\?$)|^[\\a-zA-Z. :0-9-]*\\\/?(.*)" & @CRLF & _
"(^\w*[ а-яА-Яa-zA-Z:,\/]*\\?$)|^\\*[\w .:]*\\*\/?(.*)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")