import Foundation
let pattern = #"(^\w*[ а-яА-Яa-zA-Z:,\/]*\\?$)|^\\*[\w .:]*\\*\/?(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
\\\\atxr2.atxr.ru\\_resource_test_001001\\_dir1
c:\\_resource_test_001001\\_dir1
\\atxr2.atxr.ru\_resource_test_001001\_dir1
D:\
_dir1
\\atxr2.atxr.ru\_resource_test_001004
Локальное имя
_resource_test_001004
Разделяемое устройство
atxr.ru/Users/Administrator
atxr2.atxr.ru/_resource_test_001004
atxr2.atxr.ru\_resource_test_001004
Удаление,Смена владельца документа,Смена владельца,Удаление документа,Просмотр разрешений документа,Просмотр разрешений,Управление документами,Управление принтером,Просмотр документов,Печать,Установка разрешений документа,Установка разрешений
Подразделение Active Directory
atxr.ru/_resource_test_0011015/_resource2_test_0011015
atxr.ru/_resource_test_0011015/_user1_test_0011015
Содержание папки/Чтение данных,Чтение дополнительных атрибутов,Обзор папок/Выполнение файлов,Чтение атрибутов,Чтение разрешений
(^[\w а-яА-Я:]*\\?$)|(^[A-Z]{1}:\\$)|^[\\a-zA-Z0-9.-:]*[\\\/](.*)
(^[\w а-яА-Я:]*\\?$)|^[\\a-zA-Z. :0-9-]*\\\/?(.*)
(^\w*[ а-яА-Яa-zA-Z:,\/]*\\?$)|^\\*[\w .:]*\\*\/?(.*)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)