import re
regex = re.compile(r"(^\w*[ а-яА-Яa-zA-Z:,\/]*\\?$)|^\\*[\w .:]*\\*\/?(.*)", flags=re.MULTILINE)
test_str = ("\\\\\\\\atxr2.atxr.ru\\\\_resource_test_001001\\\\_dir1\n"
"c:\\\\_resource_test_001001\\\\_dir1\n"
"\\\\atxr2.atxr.ru\\_resource_test_001001\\_dir1\n"
"D:\\\n"
"_dir1\n"
"\\\\atxr2.atxr.ru\\_resource_test_001004\n"
"Локальное имя\n"
"_resource_test_001004\n"
"Разделяемое устройство\n"
"atxr.ru/Users/Administrator\n"
"atxr2.atxr.ru/_resource_test_001004\n"
"atxr2.atxr.ru\\_resource_test_001004\n"
"Удаление,Смена владельца документа,Смена владельца,Удаление документа,Просмотр разрешений документа,Просмотр разрешений,Управление документами,Управление принтером,Просмотр документов,Печать,Установка разрешений документа,Установка разрешений\n"
"Подразделение Active Directory\n"
"atxr.ru/_resource_test_0011015/_resource2_test_0011015\n"
"atxr.ru/_resource_test_0011015/_user1_test_0011015\n"
"Содержание папки/Чтение данных,Чтение дополнительных атрибутов,Обзор папок/Выполнение файлов,Чтение атрибутов,Чтение разрешений\n\n"
"(^[\\w а-яА-Я:]*\\\\?$)|(^[A-Z]{1}:\\\\$)|^[\\\\a-zA-Z0-9.-:]*[\\\\\\/](.*)\n"
"(^[\\w а-яА-Я:]*\\\\?$)|^[\\\\a-zA-Z. :0-9-]*\\\\\\/?(.*)\n"
"(^\\w*[ а-яА-Яa-zA-Z:,\\/]*\\\\?$)|^\\\\*[\\w .:]*\\\\*\\/?(.*)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")