using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^a((b(?2)?)a)?(?1)*$";
string input = @"# pass
a
aba
ababba
ababbabbba
ababbabbbabbbba
# fail
aa
abbaa
abba
aabb
abababa
ababbba
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}