package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^a((b(?2)?)a)?(?1)*$`)
var str = `# pass
a
aba
ababba
ababbabbba
ababbabbbabbbba
# fail
aa
abbaa
abba
aabb
abababa
ababbba
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}