#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(http:\/\/|https:\/\/)?(www\.)?[a-zA-Z0-9-_\.]+\.[a-zA-Z]+(:\d+)?(\/[a-zA-Z\d\.\-_]*)*[a-zA-Z.!@#$%&=-_'":,.?\d*)(]*$"
Local $sString = "http://preview.ynot.com:80/cgibin/nd_CGI-50.cgi/YnotPhoenix/CFsMain" & @CRLF & _
"https://the-parrot-lands.com/ewefwe/fwefwe/jljlk%hkuj" & @CRLF & _
"http://twas.brillig.and.the.slithy.toves." & @CRLF & _
"http://csrpathway.com" & @CRLF & _
"https://google.com" & @CRLF & _
"https://google.com:8080/" & @CRLF & _
"parrotlands.com/" & @CRLF & _
"http://www.google.com/aa" & @CRLF & _
"http://www.google.com" & @CRLF & _
"https://regex101.info" & @CRLF & _
"http://a.com:8080/asdfas.php?as=3729&asd=df&a=*)fw3287&asdf=223" & @CRLF & _
"101_regix.com/aaa/" & @CRLF & _
"t.me/anhnch" & @CRLF & _
"ig.me/aa/33/22/332833/adasd/eoe/owerw.php" & @CRLF & _
"ww.com/index.php?asd=339298" & @CRLF & _
"http://art.com/artgallery/default.asp?sid=9DF4BC0580DF11D3ACB60090271E26A8&command=freelist" & @CRLF & _
"http://www.drugemporium.com/cec/cstage?eccookie=@eccookie@&ecaction=de_ecwalkin&template=de_walkin.en.htm" & @CRLF & _
"http://www.sfgate.com/cgibin/srch_archive/dropdn_srch.cgi?template=templates2Ftypes2Ffood2Ffd_ddstemplate.shtml&item=templates%2Ftypes%2Ffood%2Ffd_ddsitem.txt&subject=RESTAURANTS%2BAND%2BREVIEW&keyword=shrimp&datesearch=366&year="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")