const regex = /^(http:\/\/|https:\/\/)?(www\.)?[a-zA-Z0-9-_\.]+\.[a-zA-Z]+(:\d+)?(\/[a-zA-Z\d\.\-_]*)*[a-zA-Z.!@#$%&=-_'":,.?\d*)(]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http:\\\/\\\/|https:\\\/\\\/)?(www\\.)?[a-zA-Z0-9-_\\.]+\\.[a-zA-Z]+(:\\d+)?(\\\/[a-zA-Z\\d\\.\\-_]*)*[a-zA-Z.!@#$%&=-_\'":,.?\\d*)(]*$', 'gm')
const str = `http://preview.ynot.com:80/cgibin/nd_CGI-50.cgi/YnotPhoenix/CFsMain
https://the-parrot-lands.com/ewefwe/fwefwe/jljlk%hkuj
http://twas.brillig.and.the.slithy.toves.
http://csrpathway.com
https://google.com
https://google.com:8080/
parrotlands.com/
http://www.google.com/aa
http://www.google.com
https://regex101.info
http://a.com:8080/asdfas.php?as=3729&asd=df&a=*)fw3287&asdf=223
101_regix.com/aaa/
t.me/anhnch
ig.me/aa/33/22/332833/adasd/eoe/owerw.php
ww.com/index.php?asd=339298
http://art.com/artgallery/default.asp?sid=9DF4BC0580DF11D3ACB60090271E26A8&command=freelist
http://www.drugemporium.com/cec/cstage?eccookie=@eccookie@&ecaction=de_ecwalkin&template=de_walkin.en.htm
http://www.sfgate.com/cgibin/srch_archive/dropdn_srch.cgi?template=templates2Ftypes2Ffood2Ffd_ddstemplate.shtml&item=templates%2Ftypes%2Ffood%2Ffd_ddsitem.txt&subject=RESTAURANTS%2BAND%2BREVIEW&keyword=shrimp&datesearch=366&year=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}