using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{{\s*((?:(?!{{|}})[^-])*-.*?)\s*}}";
string input = @"{{ }} {{ SITE_AGGREGATE_SUBNET }}.3 remote-as {{ BGP-AS }} {{ }} {{ SITE_AGGREGATE_SUBNET }}.3 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}