$re = '/{{\s*((?:(?!{{|}})[^-])*-.*?)\s*}}/m';
$str = '{{ }} {{ SITE_AGGREGATE_SUBNET }}.3 remote-as {{ BGP-AS }} {{ }} {{ SITE_AGGREGATE_SUBNET }}.3 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);