re = /{{\s*((?:(?!{{|}})[^-])*-.*?)\s*}}/m
str = '{{ }} {{ SITE_AGGREGATE_SUBNET }}.3 remote-as {{ BGP-AS }} {{ }} {{ SITE_AGGREGATE_SUBNET }}.3 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end