using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^05[023489]-?\d{3}-?\d{4}$";
string input = @"The match rules are:
Starts with 05, then one of: 0, 2, 3, 4, 8, 9
then Optional Hyphen
then 3 digits
then Optional '-'
Ultimately come 4 digits.
A few examples to Valid phone numbers:
052-587-6549
0531432941
058-3219321
059-321-1353";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}