import Foundation
let pattern = #"^05[023489]-?\d{3}-?\d{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
The match rules are:
Starts with 05, then one of: 0, 2, 3, 4, 8, 9
then Optional Hyphen
then 3 digits
then Optional '-'
Ultimately come 4 digits.
A few examples to Valid phone numbers:
052-587-6549
0531432941
058-3219321
059-321-1353
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)