# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^05[023489]-?\d{3}-?\d{4}$"
test_str = ("The match rules are:\n\n"
"Starts with 05, then one of: 0, 2, 3, 4, 8, 9\n"
"then Optional Hyphen\n"
"then 3 digits\n"
"then Optional '-'\n"
"Ultimately come 4 digits.\n"
"A few examples to Valid phone numbers:\n\n"
"052-587-6549\n"
"0531432941\n"
"058-3219321\n"
"059-321-1353")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.