#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)translate\((\-?\d+\.?\d*)\,\s?(\-?\d+\.?\d*)"
Local $sString = "translate(-140.897155855, 10.897155855) scale(2.1885874025214793)" & @CRLF & _
                "translate(-140.897155855, -123.897155855) scale(2.1885874025214793)" & @CRLF & _
                "scale(2.1885874025214793) translate(-140.897155855, -123.897155855)" & @CRLF & _
                "scale(2.1885874025214793) translate(1, 0)" & @CRLF & _
                "scale(2.1885874025214793) translate(0,0)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")