import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "translate\\((\\-?\\d+\\.?\\d*)\\,\\s?(\\-?\\d+\\.?\\d*)";
final String string = "translate(-140.897155855, 10.897155855) scale(2.1885874025214793)\n"
+ "translate(-140.897155855, -123.897155855) scale(2.1885874025214793)\n"
+ "scale(2.1885874025214793) translate(-140.897155855, -123.897155855)\n"
+ "scale(2.1885874025214793) translate(1, 0)\n"
+ "scale(2.1885874025214793) translate(0,0)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}