#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^((?!--).)*?abc.*?$"
Local $sString = "abc" & @CRLF & _
"--abc" & @CRLF & _
"text abc --abc --this line should match on the first occurrence of "abc"" & @CRLF & _
" 1234abc" & @CRLF & _
"--abc" & @CRLF & _
"-- abc" & @CRLF & _
" -- abc" & @CRLF & _
"--abc" & @CRLF & _
"abc" & @CRLF & _
"aaabbbccc" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")