import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^((?!--).)*?abc.*?$";
final String string = "abc\n"
+ "--abc\n"
+ "text abc --abc --this line should match on the first occurrence of \"abc\"\n"
+ " 1234abc\n"
+ "--abc\n"
+ "-- abc\n"
+ " -- abc\n"
+ "--abc\n"
+ "abc\n"
+ "aaabbbccc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}