const regex = /(?i)^((?!--).)*?abc.*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^((?!--).)*?abc.*?$', 'gm')
const str = `abc
--abc
text abc --abc --this line should match on the first occurrence of "abc"
1234abc
--abc
-- abc
-- abc
--abc
abc
aaabbbccc
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}