const regex = /(?<=\d)-/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)-', 'gm')
const str = `dfwx--05-dfpixc3-dfwx--8-dfpixc3`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);