import re
regex = re.compile(r"(?<=\d)-", flags=re.MULTILINE)
test_str = "dfwx--05-dfpixc3-dfwx--8-dfpixc3"
subst = "\\n"
result = regex.sub(subst, test_str)
if result:
print(result)