re = /(?<=\d)-/m
str = 'dfwx--05-dfpixc3-dfwx--8-dfpixc3'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result