package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(string\d+)`)
var str = `DD-JSH-String43423213-3774
DE-String43423214-SDC-3721`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}