$re = '/(?i)(string\d+)/m';
$str = 'DD-JSH-String43423213-3774
DE-String43423214-SDC-3721';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);