re = /(?i)(string\d+)/m
str = 'DD-JSH-String43423213-3774
DE-String43423214-SDC-3721'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end