using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^ab]*+(?=(?:[^b]*b){2})(?:[^a]*a){2}[^a]*$";
string input = @"---aabb+++
---bbaa+++
---abab+++
---baba+++
---babba++
---bbbbbaa
ababbb++++
ccabcab+++
----bcdbaa
-ababd++++
bbbaabbbbb
bbbabbbbbb
bbbaaabbbb
baaaaaaaaa
abbbbbbbbb
ccacbcacbc
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}