import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^ab]*+(?=(?:[^b]*b){2})(?:[^a]*a){2}[^a]*$";
final String string = "---aabb+++\n"
+ "---bbaa+++\n"
+ "---abab+++\n"
+ "---baba+++\n"
+ "---babba++\n"
+ "---bbbbbaa\n"
+ "ababbb++++\n"
+ "ccabcab+++\n"
+ "----bcdbaa\n"
+ "-ababd++++\n"
+ "bbbaabbbbb\n"
+ "bbbabbbbbb\n"
+ "bbbaaabbbb\n"
+ "baaaaaaaaa\n"
+ "abbbbbbbbb\n"
+ "ccacbcacbc\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}