package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<li>Артикул: <span>(.{3,24})<\/span><\/li>`)
var str = `<li>Артикул: <span>СТРОКА</span></li>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}