re = /<li>Артикул: <span>(.{3,24})<\/span><\/li>/m
str = '<li>Артикул: <span>СТРОКА</span></li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end