$re = '/<li>Артикул: <span>(.{3,24})<\/span><\/li>/m';
$str = '<li>Артикул: <span>СТРОКА</span></li>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);