package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(?:\(\d+\))?(.+)`)
var str = `Section 78(1) of the blabla
Section 78 of the blabla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}