$re = '/\d+(?:\(\d+\))?(.+)/m';
$str = 'Section 78(1) of the blabla
Section 78 of the blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);