re = /\d+(?:\(\d+\))?(.+)/m
str = 'Section 78(1) of the blabla
Section 78 of the blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end