import re
regex = re.compile(r"img.*?title=\"([^\"]+)\"\s*src=\"([^\"]+)\"")
test_str = "<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写<img alt=\"大气超级品牌日活动宣传海报\" title=\"大气超级品牌日活动宣传海报\" src=\"http://pic.qiantucdn.com/58pic/26/32/41/49258PICQdJ.jpg!qt226\" width=\"226\" height=\"546\" /> 请问只取title和src 应该怎么写"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")