using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<offer.*available=""false"">";
string input = @"<parent>
<offer различный текст available=""false"">
рандомный текст
рандомный текст
</offer>
<offer различный текст available=""true"">
рандомный текст
рандомный текст
</offer>
<offer различный текст available=""false"">
рандомный текст
рандомный текст
</offer>
<offer различный текст available=""true"">
рандомный текст
рандомный текст
</offer>
<offer различный текст available=""true"">
рандомный текст
рандомный текст
</offer>
</parent>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}