$re = '/<offer.*available="false">/';
$str = '<parent>
<offer различный текст available="false">
рандомный текст
рандомный текст
</offer>
<offer различный текст available="true">
рандомный текст
рандомный текст
</offer>
<offer различный текст available="false">
рандомный текст
рандомный текст
</offer>
<offer различный текст available="true">
рандомный текст
рандомный текст
</offer>
<offer различный текст available="true">
рандомный текст
рандомный текст
</offer>
</parent>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);