re = /<offer.*available="false">/
str = '<parent>
<offer различный текст available="false">
рандомный текст
рандомный текст
</offer>
<offer различный текст available="true">
рандомный текст
рандомный текст
</offer>
<offer различный текст available="false">
рандомный текст
рандомный текст
</offer>
<offer различный текст available="true">
рандомный текст
рандомный текст
</offer>
<offer различный текст available="true">
рандомный текст
рандомный текст
</offer>
</parent>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end