package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Forms (?P<Codigo>(ORA|FRM)-\d+) (?P<Texto>.*)`)
var str = `Forms FRM-40010 Cannot read bla, bla, bla
Forms ORA-12514 TNS:listener does not currently know of service requested in connect descriptor
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}