re = /Forms (?P<Codigo>(ORA|FRM)-\d+) (?P<Texto>.*)/m
str = 'Forms FRM-40010 Cannot read bla, bla, bla
Forms ORA-12514 TNS:listener does not currently know of service requested in connect descriptor
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end