use strict;
my $str = 'Forms FRM-40010 Cannot read bla, bla, bla
Forms ORA-12514 TNS:listener does not currently know of service requested in connect descriptor
';
my $regex = qr/Forms (?P<Codigo>(ORA|FRM)-\d+) (?P<Texto>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}