re = /\"processing_stage\": \"(?<response>[^\"]+)/m
str = '"processing_stage": "Getting a response of 403 from CRM Lead"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end