package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(from \/projects(?:\/[^\/]+)*:\d+\)$`)
var str = `(from /projects/idpro/branches/release_2018/test/test/test.1:13118)
(from /projects/idpro/trunk:13074)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}