const regex = /^\(from \/projects(?:\/[^\/]+)*:\d+\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\(from \\\/projects(?:\\\/[^\\\/]+)*:\\d+\\)$', 'gm')
const str = `(from /projects/idpro/branches/release_2018/test/test/test.1:13118)
(from /projects/idpro/trunk:13074)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}