$re = '/^\(from \/projects(?:\/[^\/]+)*:\d+\)$/m';
$str = '(from /projects/idpro/branches/release_2018/test/test/test.1:13118)
(from /projects/idpro/trunk:13074)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);