$re = '/\n+|\t+|\r+|\s{2,}/m';
$str = '.b-block_warranty__side_right-end-link{
outline:none !important;
font-size:14px;
line-height:16px;
color:#64a0d1;
font-weight:400;
border-bottom:1px dashed #64a0d1;
-webkit-transition:all 0.5s ease;
-o-transition:all 0.5s ease;
transition:all 0.5s ease;
}
.b-block_warranty__side_right-end-link_hidden{
display:none;
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);