import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([а-яА-Я0-9.,]+(\\s)(см|см.))";
final String string = "черный анальный стимулятор с 4-мя шариками разными по диаметру. имеется удобная ручка для удерживания. шарики украшены пупырашками для большего удовольствия. материал изготовления tpr. диаметр шариков варьируется от 2 см 3 см. длина - 14 см. упаковка- блистер. страна изготовления- китай.\n"
+ "вибратор необычной формы с загнутой головкой. изготовлен из силикона, приятен на ощупь. имеет 12 режимов вибрации. режимы переключаются при помощи кнопки в основании игрушки. работает от usb кабеля. общая длина - 21 см, рабочая длина - 15,5 см, максимальный диаметр - 4 см. упаковка - коробка с блистером.\n\n"
+ "В некоторых строках есть: - диаметр - 4 см - диаметр 4 см - диаметр шариков варьируется от 2 см 3 см";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}